MS-SQL Operator not deployed on K8S version 1.18 and 1.20? also issue with leader election in HA mode?

Aperta
#948 1 commento 1 reazione 0 assegnatari Vedi su GitHub

Nessuno ha ancora preso questa issue.

Valutazione

Difficoltà
4/5
Tempo stimato
3-5 giorni
Idoneità per principianti
18/100
Tipo di issue
Bug
Chiarezza
Da chiarire
Stato di attività
Ferma
Stack tecnologico
kubernetes, sql
Ambito
databases, devops

Direzione di ricerca

Iniziare con i file manifest di esempio collegati nell’issue e confrontare il comportamento del deployment su Kubernetes 1.13, 1.18 e 1.20 utilizzando le immagini dei container elencate. Esaminare perché i pod SQL non si avviano e controllare i log del container ha-supervisor dopo il redeployment di AG. Il lavoro è completato quando sono state identificate cause riproducibili sia dei problemi di deployment sia dei problemi di leader election, incluso l’effetto sul servizio ag-primary.

Scritto dal modello di indicizzazione a partire dal testo della issue.

Descrizione

Hi , Please provide yours's comments on following questions:-

  1. I was able to deploy MSSQL K8S Operator on K8S version 1.13 but unable to deploy on K8S version 1.18 and 1.20. I was using sample manifest file for deployments given here - "https://github.com/microsoft/sql-server-samples/tree/master/samples/features/high%20availability/Kubernetes/sample-manifest-files".
    Error : getting similar error, sql pods are not coming up, discussed in this threads - "https://stackoverflow.com/questions/63405840/k8s-sql2019-ha-containers-dude-where-are-my-pods".

for deployment, I used following images-

  1. agentsContainerImage: mcr.microsoft.com/mssql/ha:2019-CTP2.1-ubuntu

  2. sqlServerContainer: mcr.microsoft.com/mssql/server:2019-latest

  3. My second question was, once I add any database to AG, after than in any case further redeployment causing issue for failover and ag1-primary is not able to find primary pods among mssql1-0, mssql2-0, mssql3-0 . I guess there is some issue with leader election method which I was able to observe with pod ha-supervisor container logs. due to this issue client connection affected with ag-primary service.

Please let me know on these two issues?

Lingua principale
PowerShell
Stelle
11.2k
Fork
9.1k
Merge medio
2g 7h
PR unite (30g)
14

Guida per i contributori

Nessuna guida per i contributori indicizzata per questo repository

Come iniziare

  1. Leggi tutta la issue e poi la guida ai contributi del progetto.
  2. Commenta sulla issue per dire che te ne occupi tu — evita che due persone facciano lo stesso lavoro.
  3. Fai un fork del repository e lavora su un branch.
  4. Apri una pull request che faccia riferimento al numero della issue.

Altre issue di microsoft/sql-server-samples

Tutte le issue di microsoft/sql-server-samples

Issue simili

Altre issue su Databases

Ricevi le nuove issue nella tua casella

Un breve riepilogo di issue GitHub adatte ai principianti.