azure scheduled query rules ARM template
- Dominant language
- Python
- Stars
- 4.6k
- Forks
- 3.5k
- Avg merge
- 3d 2h
- Merged PRs (30d)
- 60
Description
### Type of issue
Typo
### Reference command name
`az deployment group create --name XXX --resource-group XXX --template-file XXX.json --parameters XXX.json --mode Incremental --output json`
### Overview
This issue is similar to https://github.com/Azure/azure-cli/issues/27138.
When using `operator: Equals` as specified in the Microsoft ARM documentation, the request fails with the error: `Requested value 'Equals' was not found.`
### Feedback
Upon investigation, it appears that the correct value should be `Equal`, as confirmed by inspecting the actual network request on the portal. This discrepancy between the documentation and expected value leads to confusion and failed deployments.
```json
{
"properties": {
"criteria": {
"allOf": [
{
"query": "AzureActivity | where TimeGenerated > ago(1h) | where OperationNameValue contains \"Microsoft.ContainerService/managedClusters/agentpools/write\" | where ActivityStatusValue == \"Started\"",
"timeAggregation": "Count",
"dimensions": [],
"resourceIdColumn": "",
"operator": "Equal",
"threshold": 1,
"failingPeriods": {
"numberOfEvaluationPeriods": 1,
"minFailingPeriodsToAlert": 1
}
}
]
}
}
}
```
After digging into the CLI extension where operator conversion is performed, it seems like the correct operator to be using is `Equal` instead of `Equals`.
https://github.com/Azure/azure-cli-extensions/blob/main/src/scheduled-query/azext_scheduled_query/grammar/scheduled_query/ScheduleQueryConditionValidator.py
I have attempted to change the operator to `Equal` inside the ARM template, and the deployment is able to go through successfully. I have yet to test both terraform and bicep template, but it might be worth updating the mentioned attribute in both documentation as well.
### Page URL
https://learn.microsoft.com/en-us/azure/templates/microsoft.insights/2022-06-15/scheduledqueryrules?pivots=deployment-language-arm-template
### Content source URL
_No response_
### Author
_No response_
### Document Id
_No response_
Contributor guide
Assessment
This issue has not been assessed yet.